» » » » WEB Sayfa Taşıma Sonrasında TinyMCE (WYSIWYG) Editör hatası

WEB Sayfa Taşıma Sonrasında TinyMCE (WYSIWYG) Editör hatası

Özkan
Özkan 28-12-2014, 22:50
Merhaba arkadaşlar

Web sayfalarımı bir Reseller firmasında yaşımış olduğum sıkıntı yüzünden taşımak zorunda kaldım. Web sayfalarım sıkıntısız taşınmıştır. 3 türlü taşıma işlemini denedim. 1. Sıfırdan DLE 10.3 kurup DLE 'nin BACKUP klasörüne son yedeği atıp çağırarak gerçekleştirdim. 2. Eski resellerden dosyaları dahi yeni reseller hesaba atıp cpanel Database yükledim. 3. Eski resellerdan dosyaları taşıdım ve DLE 'nin BACKUP klasörüne son yedeği atıp çağırarak gerçekleştirdim. Sonuç itibari ile aynı hata ile karşı karşıya kaldım.
Karşılaştığım hata ise ben tüm web sayfalarımda TinyMCE (WYSIWYG)editör kulanıyorum admin panelden. Site taşımaları sonrasında MAKALE DÜZENLE'ye girdiğimde konuda yazmakta olan yazılar görünmemektedir. Fakat sitede sorunsuz yayınlanmaktadır. Editleme işlemi artık yapılamıyor. Hatta Konu Ekleme bile yapamıyorum!
Tüm Panel Bölümleri>Sistem Ayarları>Sabit Sayfalarda WYSIWYG Editör Kullanımı Etkinleştir: [Standart (BBCODES)]
ve Yönetici KP Alanında WYSIWYG Editör Kullanımını Etkinleştir: [Standart (BBCODES)] yaptığımda MAKALE DÜZENLE ve MAKALE EKLE içeriği görünmektedir. Fakat html kod ile görünmektedir. Bu hatayı nasıl aşabilirim.

Yardımınızı bekliyorum. Şimdiden teşekkürler

TinyMCE (WYSIWYG)
Çözüldü İşleme Alındı Bekliyor Çözülemedi
Bilgilendirme
Yorum Ekleyebilmeniz için Sitemize Kayıt Olmanız Gerekmektedir.
3 745
MaRZoCHi 1 Ocak 2015 07:00
@Özkan, @mrt806 sanıyorum hata benden kaynaklı. WYSIWYG Editörleri kullanmadığım için fazla deneme yapmıyorum ondan dolayı bu durum paketlere yansıyabiliyor. Kusura bakmayın...
DLE 10.3 Türkçe Paketi güncellenmiştir.

--------------------
0
0
Özkan 1 Ocak 2015 02:24
@mrt806, kardeşim engine/editor/jscripts/tiny_mce/langs klasörüne girdim. tr_TR.js olan ismini tr.js olarak değiştirdim ve sorun bende düzeldi. İşin ilginç kısmı ise DLE 10.2 zaten o dosyanın ismi tr.js olarak geçiyor. DLE 10.3 de belki bu dosya son güncelleme ile dosyanın çağrılma ismi değiştirildi yada dosyanın adı yanlış değiştirildi. Bir olasılık daha var diyecektim ki tr.js dosya ismini otr.js olarak değiştirdim yine hata verdi. Dosyaya ulaşamadığı için sanırım :) Sonuç itibari ile dosya isminden kaynaklı gibi. @mrt806 kardeşim bu arada teşekkür ederim sorun bende de böylelikle çözüldü :)
0
103
mrt806 1 Ocak 2015 01:19
@Özkan, kardeşim ben hiç kullanmıyordum ama sen dedikten sonra denedim ve bende de ücretli 2 farklı hosting firmasında barınan sitelerimde hata verdi. Ama ne hikmetse hostinger de ücretsiz olarak barınan sitemde sorunsuz çalışıyor anlamadım ama hosting kaynaklı olabilir bu sorun. Neyse Deneme yanılma ile çözümü buldum :)

Sorunun çözümü : engine/editor/jscripts/tiny_mce/langs klasörüne gir ve tr_TR.js olan dosya ismini tr.js olarak değiştir sorun düzeliyor.
0
0
Özkan 1 Ocak 2015 01:02
DLE 10.3 tamamen hatalı demedim. Standart (BBCODES) Editörde sıkıntısız çalışıyor. Fakat TinyMCE (WYSIWYG) editörü seçtiğimde Makale Ekle, Makale Düzenle kısmında Makale, Sorgu, İlave, Erişim sekmeleri açılıyor. Ama Makale kısmındaki editör çalışıyor. PHP, HTML uzmanı değilim. Buda bir gerçek. Ama ortada büyük bir sorun var. Belkide arkadaşlar Standart (BBCODES) Editör kullandıkları için şimdiye kadar farkına varamadılar. TinyMCE (WYSIWYG) editörü ben kullandığım için bu hata ile karşılaştım. @MaRZoCHi Haklı olabilirsin. Modül yazdığına göre PHP Kodları biliyorsun. GWBASIC, QBASIC, VISUAL BASIC desen hatanın nereden kaynaklandığını söylerim. Ama bu kodlama beni aşıyor. DLE 10.3' ün Standart (BBCODES) Editör çalışıpta, TinyMCE (WYSIWYG) editörü aktif ettiğimde hata yapması bu yüzden saçma geldi. Aslında DLE 10.3'ü TinyMCE (WYSIWYG) editörü kullananlarda buraya yorum yazsa iyi olur. Sorun sadece bende mi! Bu işlemleri 2 ayrı firmadan aldığım reseller larda denedim. Aynı sonucu aldım. Ve o yüzden HATA VAR diye yazdım. Benim derdim bu sorunun giderilmesi. Maalesef TinyMCE (WYSIWYG) editörü kullanmak zorundayım. Yada DLE 10.3 den DLE 10.2 ye geri dönüş yapacam. Bu hatadan ötürü web sayfama 1 aydır konu giremiyorum. Çok sıkıntı çekmekteyim.
0
0
mehmet 31 Aralık 2014 22:24
ben yaklaşık 2 hafta önce web sitemi baştan full olarak taşıdım bir kaç sıkıntı dışında hepsini düzenledim benim taşıma yöntemim sql iledir. Benimle bağlantı kur gereken yardımı sağlarım. Saygılarımla
0
3 745
MaRZoCHi 31 Aralık 2014 19:49
@Özkan, sorunu yerinde incelemek gerekli bu durumlarda. Yaptığınız denemelere göre. Uyumsuzluk / Hata olduğu aşikar. Fakat yine de hata diye kesin konuşmak hatalıdır. Scriptin 10.2 ve 10.3 sürümleri arasında bir takım farklılıklar var. Bunların çoğu güncel kütüphaneler/sistem için yapılmıştır. Uyumsuzluk problemi de olabilir.

--------------------
0
0
Özkan 31 Aralık 2014 19:06
Son Noktayı koyuyorum. Sıfırdan 2 Adet DLE 10.2 ve DLE 10.3 kurdum. İlk Bilgilendirme kategorisinde ekli olarak Hoş Geldiniz konusu edit yaptım.
Kurulumda Tüm Panel Bölümleri>Sistem Ayarları>Sabit Sayfalarda WYSIWYG Editör Kullanımı Etkinleştir: [Standart (BBCODES)] seçili geldiği için bende TinyMCE (WYSIWYG)editörü seçtim. Çok ilginç sonuç gördüm. DLE 10.3 Script editörü açmadı! Fakat aynı işlemleri uygulamış olduğum 10.2 de TinyMCE (WYSIWYG) Editör açıldı. Sonuç itibari ile DLE 10.3 SCRİPT de HATA VAR!!!!

DLE 10.3 Kullanmayın! DLE 10.2 kullanın!
0
0
Özkan 30 Aralık 2014 22:18
Yeni taşıdığım reseller firması güvenlik açığından ötürü en son sürümlerden açık olduğundan ötürü kaçınıyor. Haklıda! 15 Ocak 2015 de bir üst versiyona yükselteceğini belirtti. İşin tuhafı önceki reseller' da web sitem php_zip hatası ile log MByte larca oluşuyordu. Fakat şimdi hata log u oluşmuyor. 15 Ocakta güncelleme belli olacak o ihtimal. Yukarda bahsetmiş olduğum konu şuanda tüm web sayfalarımda mevcut. Keşke TinyMCE kullanmasaydımda Standart (BBCODES) kullansaydım diyede pişman olmamışta değilim hani! Anlaşılan bu hatanın kaynağına kimse denk gelmemiş.
0
597
marika 30 Aralık 2014 02:05
BBcode de gelip diğerinde gelmemesi çok ilginç.

Yine TinyMCE editörün php dosyalarının sunucu tarafından çalıştırılaması geliyor akla. Çünkü makale verileri veri tabanından çekilip TinyMCE editöüre uygun şekilde textarea da gösteriliyor bize. TinyMCE de sorun olunca gösteremiyor.

Yeni geçiş yaptığınız sunucunun bir ayarından veya php versiyonundan bile olabilir. onu ancak Mehmet hoca yapabilir. 1 hafta sonra filan Mehmet hocanın işleri biter ücretli olarak ona yaptırabilirsiniz yapmak isterse. Bu konuyu kendisine hatırlatın 1 hafta sonra.
0
0
Özkan 29 Aralık 2014 21:25
Selam

Dosyalarda sıkıntı yok!. Birebir konular web sayfamda gösterimde. Fakat Admin Panel den Makale Düzenle kısmına girdiğimde TinyMCE (WYSIWYG)sistem ayarlarında seçili iken görünmüyor ve link ekleme kod ekleme yazı inceltme kalınlaştırma o menü dahi görünmüyor. Ama sistem ayarlarında Standart (BBCODES) seçtiğimde menüde geliyor ve eklemiş olduğum konunun içeriğide HTML kodlar halinde görünmektedir. Siteme bu hatadan ötürü konu dahi ekleyemiyorum. TinyMCE (WYSIWYG) editör kullanarak hep konularımı onlara göre hazırlamıştım. Şimdi ise Standart (BBCODES) kullanmadığım için bir nevi cezalandırılmış gibi oldum. Yardım lazım... Bu hatayı tüm DLE web sayfalarımda mevcut.
0
597
marika 29 Aralık 2014 20:51
Dosyalar eksik taşınmıştır büyük olasılıkla. Kurulmamış DLE dosyaları içindeki dosyaların hepsini ftp var mı diye kontrol edermisin?

Ayrıca eskisi ile yeni mysql ayarlarındaki farklılıklardan da olabilir.
0
İSTATİSTİKLER