» » » » Veritabanı hatası

Veritabanı hatası

KCA
KCA 4-07-2016, 18:30
MySQL Error!
MySQL error in file: /engine/inc/addnews.php at line 749
Error Number: 1406
The Error returned was:
Data too long for column 'tags' at row 1
SQL query:

etiket sayisi bir kac tane olunca hata vermiyor ama biraz fazla oldumu hata veriyor neden ?

URL:http://www.akvaryumbilgi.net

Çözüldü İşleme Alındı Bekliyor Çözülemedi
Bilgilendirme
Yorum Ekleyebilmeniz için Sitemize Kayıt Olmanız Gerekmektedir.
0
KCA 7 Temmuz 2016 00:14
bu şekilde ne başta düzenlemiştim yinede olmamişti. internette araştirinca altaki yorumdaki gibi hosttan kaynaklaniyormuş
0
3 746
MaRZoCHi 4 Temmuz 2016 22:50
dle_tags tablosunda tag kolonu için karakter limit 100 olarak ayarlanmış varchar(100) bunu arttırabilirsiniz. ( phpMyAdmin > dle_tags > Yapı -> tag > Değiştir )

--------------------
0
0
KCA 4 Temmuz 2016 21:14
türkceye cevirip o kadarını bende anladim. ama düne kadar böyle bir sorun yokken neden durduk yere verdi böyle hata. nasil düzeltirim. dle veritabaninda sıkıntı var hangi sütunlari yada sorgulamalari yapinca düzelecek onu ögrenmek istiyorum.

@MaRZoCHi, dedigin gibi arattirdim googlede hosttan kaynaklaniyormuş.
Mail attim bakalim.

i want disable strict mode in MySQL 5 ():

Edit /my.ini and look for line
sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION&qu
ot;
Replace it with
sql_mode='MYSQL40'
Restart the MySQL service (assuming that it is mysql5)
net stop mysql5
net start mysql5
If you have root/admin access you might be able to execute

mysql_query("SET @@global.sql_mode='MYSQL40'");
0
3 746
MaRZoCHi 4 Temmuz 2016 19:49
İlk olarak başlıklara değineceğim; ü ve ö harflerini kullanabildiğinize göre klavyeniz Türkçe karakterleri destekliyor. Bu nedenle "Veritabani hatasi" yerine "Veritabanı hatası" yazmanı gerekli konunuz onaylansın. Son kez manuel olarak düzenleyip onayladım. Kaldı ki kurallarda bu belirtilmiş. Aynı şekilde eklediğiniz sonraki konularını onaylanmayacaktır...

Veritabanı hatası görünce direkt olarak bunu sisteme bağlamak yanlıştır. İlk olarak aldığınız hatayı araştırabilirsiniz.
Data too long for column

Çeviri yapılarak bile sorun anlaşılabilir. Kolona girilen değerin uzun olduğunu söylüyor. Yani girdiğiniz etiketler çok uzun. Ayrıca şu konuyu da araştırın derim: Etiket Kullanımı SEO ilişkisi

--------------------
0
İSTATİSTİKLER