» » » » Modülleri 10.3'e uyarlama

Modülleri 10.3'e uyarlama

MaRZoCHi
MaRZoCHi Kurucu 3-09-2014, 23:53
Her DLE sürümünde olduğunu gibi 10.2'den 10.3'e geçişte de sistem dosyalarında, modül yazarlarını ilgilendirecek değişiklikler var.
Eğer 10.2'den 10.3'e uyarlama yapacaksanız bu işlem oldukça kolay. Fakat 10.2 öncesi için, modüle bağlı olarak zorluklar olacaktır.

10.2'den 10.3'e geçiş

10.3 için eklenen özelliklerden biri de saat dilimi ayarı idi. Yeni PHP sürümleri için gereken bir durum olduğu için eklendi. Muhtemelen sunucularında PHP'nin yeni sürümlerini kullanan kullanıcılar buna bağla hata ile karşılaşmışlardır.

Değişiklikler :

- Eğer kullandığınız modüllerin engine/ajax klasöründe dosyası varsa bu düzenlemeyi yapmanız gereklidir. Aksi halde ajax dosyasından bilgi alırken, aldığınız çıktının baş kısmına hata yazıları ekleneceği için çıktıyı başarıyla işleyemeyeceksiniz.

Bul: ( Eğer yoksa data/config.php içeren bir satırı bulun. Başlangıç include yerine require, require_once, include_once olabilir )
include ENGINE_DIR.'/data/config.php';


Altına ekle :
date_default_timezone_set ( $config['date_adjust'] );


Aşağıdaki resim ile daha açıklayıcı olacaktır.

10.2 ve 10.3 arasındaki PHP farkları ( ajax )10.2 ve 10.3 arasındaki PHP farkları ( ajax )

İyi çalışmalar...
Bilgilendirme
Yorum Ekleyebilmeniz için Sitemize Kayıt Olmanız Gerekmektedir.
597
marika 4 Eylül 2014 15:55
Elinize sağlık.
0
İSTATİSTİKLER